玄箱HGにFedoraを入れて自宅サーバを構築 - Amonution

Fedora8にアップグレード

以下の手順は途中で一度失敗しており、もしかすると完全にFedora8になっていない可能性があります。
それを踏まえた上で観覧ください。

パッケージの更新

Fedora8にアップグレードする前に、現在のパッケージを最新に更新します。

fedora-releaseとfedora-release-notesをアップデート

最初にfedora-releaseとfedora-release-notesをアップデートします。

[root@KURO-F7 ~]# rpm -Uvh \
> http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/fedora-release-8-3.noarch.rpm \
> http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/fedora-release-notes-8.0.0-3.noarch.rpm

http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/fedora-release-8-3.noarch.rpm を取得中
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/fedora-release-notes-8.0.0-3.noarch.rpm を取得中
警告: /var/tmp/rpm-xfer.HI2uqb: ヘッダ V3 DSA signature: NOKEY, key ID 4f2a6fd2
準備中...                ########################################### [100%]
   1:fedora-release-notes   ########################################### [ 50%]
   2:fedora-release         ########################################### [100%]
[root@KURO-F7 ~]#

警告が出ていますが、とりあえず気にしないことにします。
続いてyumをアップデートします。

[root@KURO-F7 ~]# rpm -Uvh \
> http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/yum-3.2.7-1.fc8.noarch.rpm

http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/yum-3.2.7-1.fc8.noarch.rpm を取得中
警告: /var/tmp/rpm-xfer.MreaNj: ヘッダ V3 DSA signature: NOKEY, key ID 4f2a6fd2
エラー: 依存性の欠如:
        python-iniparse は yum-3.2.7-1.fc8.noarch に必要とされています

python-iniparse が不足しているので、先にそちらをアップデートします。

[root@KURO-F7 ~]# rpm -Uvh \
> http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/python-iniparse-0.2.2-1.fc8.noarch.rpm

http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/python-iniparse-0.2.2-1.fc8.noarch.rpm を取得中
警告: /var/tmp/rpm-xfer.ZoM7kH: ヘッダ V3 DSA signature: NOKEY, key ID 4f2a6fd2
準備中...                ########################################### [100%]
   1:python-iniparse        ########################################### [100%]

もう一度yumをアップデートします。

[root@KURO-F7 ~]# rpm -Uvh \
> http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/yum-3.2.7-1.fc8.noarch.rpm

http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/ppc/os/Packages/yum-3.2.7-1.fc8.noarch.rpm を取得中
警告: /var/tmp/rpm-xfer.6qNS4t: ヘッダ V3 DSA signature: NOKEY, key ID 4f2a6fd2
準備中...                ########################################### [100%]
   1:yum                    ########################################### [100%]

インストールしたyumを使ってupgradeする。

念のためcleanを実行する
[root@KURO-F7 ~]# yum clean all
Cleaning up Everything

[root@KURO-F7 ~]# yum upgrade
fedora                    100% |=========================| 2.1 kB    00:00
primary.sqlite.bz2        100% |=========================| 5.8 MB    00:02
updates                   100% |=========================| 2.3 kB    00:00
primary.sqlite.bz2        100% |=========================| 746 kB    00:00
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package tcl.ppc 1:8.4.15-5.fc8 set to be updated
---> Package nfs-utils-lib.ppc 0:1.1.0-3.fc8 set to be updated

    ...

---> Package mdadm.ppc 0:2.6.2-5.fc8 set to be updated
---> Package nspr.ppc 0:4.6.7-3.fc8 set to be updated
filelists.sqlite.bz2      100% |=========================| 8.7 MB    00:08
filelists.sqlite.bz2      100% |=========================| 1.6 MB    00:00
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 compat-db               ppc        4.5.20-3.fc8     fedora            3.4 M
     replacing  db4.ppc 4.5.20-5.fc7

 kernel                  ppc        2.6.23.1-49.fc8  updates            18 M
 libgssglue              ppc        0.1-4.fc8        fedora             24 k
     replacing  libgssapi.ppc 0.10-3.fc7

 util-linux-ng           ppc        2.13-3.fc8       fedora            2.0 M
     replacing  util-linux.ppc 2.13-0.51.fc7

Updating:
 ConsoleKit-libs         ppc        0.2.3-1.fc8      fedora             17 k
 audit-libs              ppc        1.6.2-4.fc8      fedora             68 k

    ...

 nspr                    ppc        4.6.7-3.fc8      fedora            136 k
 nss                     ppc        3.11.7-10.fc8    fedora            985 k
Updating for dependencies:
 db4                     ppc        4.6.21-1.fc8     fedora            644 k

Transaction Summary
=============================================================================
Install      9 Package(s)
Update     134 Package(s)
Remove       0 Package(s)

Total download size: 154 M
Is this ok [y/N]: y
Downloading Packages:
(1/143): libdhcp4client-3 100% |=========================| 269 kB    00:00
(2/143): perl-Test-Harnes 100% |=========================|  78 kB    00:00

    ...

(142/143): nfs-utils-lib- 100% |=========================|  68 kB    00:00
(143/143): tcl-8.4.15-5.f 100% |=========================| 1.8 MB    00:01
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Importing GPG key 0x4F2A6FD2 "Fedora Project <fedora@redhat.com>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : libgcc                       ##################### [  1/279]
  Updating  : setup                        ##################### [  2/279]

    ...

  Updating  : vsftpd                       ##################### [ 94/279]
  Updating  : wget                         ##################### [ 95/279]

なぜかここで止まってしまったので、いったん止めてやり直します。
もしかすると完全にFedora8になっていない可能性があります。

いったんリスタートします
[root@KURO-F7 ~]# reboot

Broadcast message from root (pts/1) (Mon Oct 18 15:55:41 2004):

The system is going down for system halt NOW!

もう一度、cleanを実行します
[root@KURO-F7 ~]# yum clean all
Cleaning up Everything

もう一度、updateを実行します
[root@KURO-F7 ~]# yum -y upgrade
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package libgssapi.ppc 0:0.11-2.fc8 set to be updated
---> Package nfs-utils.ppc 1:1.1.0-6.fc8 set to be updated

    ...

---> Package mdadm.ppc 0:2.6.2-5.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel                  ppc        2.6.23.1-49.fc8  updates            18 M
 util-linux-ng           ppc        2.13-3.fc8       fedora            2.0 M
     replacing  util-linux.ppc 2.13-0.51.fc7

Updating:
 ConsoleKit-libs         ppc        0.2.3-1.fc8      fedora             17 k
 bzip2                   ppc        1.0.4-12.fc8     fedora             51 k

    ...

 vim-minimal             ppc        2:7.1.135-1.fc8  fedora            383 k
 yum-metadata-parser     ppc        1.1.2-1.fc8      fedora             28 k
Installing for dependencies:
 dbus-libs               ppc        1.1.2-7.fc8      fedora            136 k
 mdadm                   ppc        2.6.2-5.fc8      fedora            625 k

Transaction Summary
=============================================================================
Install      4 Package(s)
Update      45 Package(s)
Remove       0 Package(s)

Total download size: 66 M
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package nfs-utils needs libgssglue, this is not available.
Package nfs-utils needs libgssglue.so.1, this is not available.

    ...

Package libtirpc needs libgssglue.so.1(libgssapi_CITI_2), this is not available.
Package nfs-utils-lib needs libgssglue, this is not available.
Complete!

リスタート前よりパッケージ数が減ったような気がしますが...
これでOKなのか自信がないですが、このまま使い始めてみることにします。

リスタートします
[root@KURO-F7 ~]# reboot

Broadcast message from root (pts/0) (Mon Oct 18 16:11:11 2004):

The system is going down for system halt NOW!

スポンサード リンク

TOPに戻る / メニューに戻る
Copyright © 1999-2011 Amonution  All rights reserved.
Address